Get the App X

Community Bank

Cutting Edge. Common Sense.

Internet Explorer 8 and Older Versions To Be Blocked

Some of our customers are accessing Internet Banking with an old version of Internet Explorer. Microsoft ended support on Internet Explorer 8 (IE8) in June 2014.

The company that provides Internet Banking has continued to allow use of Internet Explorer 8, or older versions, to access Internet Banking. However, beginning July 11, 2016, users attempting to access the system with the older versions will be blocked.

 

Why the change?

When Microsoft ends support for a product this means you may have limited functionality and are more vulnerable to computer viruses. No security patches or upgrades are being developed for older versions of Internet Explorer.

Community Bank takes the security of your financial information seriously. We strongly recommend you upgrade your Internet Browser to a more current and secure version. Currently, Internet Explorer 10 and 11 are the newest versions that will continue to allow you to access Internet Banking.

Back to latest info
Close

Important Notification: You are leaving the Community Bank Website

You have clicked on an external link that we have provided to you for a reference or resource. Although we provide these links for your benefit to learn more about specific information, we recommend that you review the privacy and security policy of other websites, as their policies may differ from our policies. We are not responsible for, endorse, guarantee or monitor the content on other websites.

You can return to the page on Community Bank that you were just viewing by closing this window, or you can click "Continue" and be taken to the external website page you requested. Thank you.